build.xml
changeset 33922 2ec0366c9fe2
parent 33879 149c47a634cf
child 33936 140e25aff39f
equal deleted inserted replaced
33921:a1b63a73a71d 33922:2ec0366c9fe2
   351     <fail message="Unsupported Java version ${ant.java.version}. Minimum required is 7 (1.7).">
   351     <fail message="Unsupported Java version ${ant.java.version}. Minimum required is 7 (1.7).">
   352       <condition>
   352       <condition>
   353         <equals arg1="${ant.java.version}" arg2="1.6"/>
   353         <equals arg1="${ant.java.version}" arg2="1.6"/>
   354       </condition>
   354       </condition>
   355     </fail>
   355     </fail>
       
   356     <antversion property="min.ant.version" atleast="1.9.2" />
       
   357     <antversion property="actual.ant.version" />
       
   358     <fail message="Unsupported ant version ${actual.ant.version}. Minimum required is 1.9.2.">
       
   359       <condition>
       
   360         <not>
       
   361           <isset property="min.ant.version"/>
       
   362         </not>
       
   363       </condition>
       
   364     </fail>
   356   </target>
   365   </target>
   357 
   366 
   358   <target name="compile.complete" depends="init, core.lib, wad.lib, trl.lib">
   367   <target name="compile.complete" depends="init, core.lib, wad.lib, trl.lib">
   359     <ant dir="${base.src}" target="compile.complete" inheritAll="true" inheritRefs="true" />
   368     <ant dir="${base.src}" target="compile.complete" inheritAll="true" inheritRefs="true" />
   360   </target>
   369   </target>