fixes 38499: raise minimum required ant version to 1.9.2
authorAsier Lostalé <asier.lostale@openbravo.com>
Tue, 08 May 2018 08:56:25 +0200
changeset 33931 1c1c62de03b1
parent 33930 b33d1c4cc375
child 33932 307b23f7635f
fixes 38499: raise minimum required ant version to 1.9.2

Check on init task current version is at least 1.9.2
build.xml
--- a/build.xml	Thu Apr 26 07:46:08 2018 +0200
+++ b/build.xml	Tue May 08 08:56:25 2018 +0200
@@ -355,6 +355,15 @@
         <equals arg1="${ant.java.version}" arg2="1.6"/>
       </condition>
     </fail>
+    <antversion property="min.ant.version" atleast="1.9.2" />
+    <antversion property="actual.ant.version" />
+    <fail message="Unsupported ant version ${actual.ant.version}. Minimum required is 1.9.2.">
+      <condition>
+        <not>
+          <isset property="min.ant.version"/>
+        </not>
+      </condition>
+    </fail>
   </target>
 
   <target name="code.rev" depends="set.code.rev">