modules/org.openbravo.client.kernel/README
author RM packaging bot <staff.rm@openbravo.com>
Fri, 26 Jul 2013 20:09:48 +0200
changeset 20796 b9e43ea5aa1b
parent 12636 3e07ffbf83e7
permissions -rw-r--r--
CI: update AD_MODULE to version 20793
harpreet@9076
     1
harpreet@9076
     2
=== old-content ===
harpreet@9076
     3
staff@10769
     4
This module has two libraries:
stefan@12636
     5
- jslint4java version 1.4.7
staff@10769
     6
- yuicompressor-2.4.2
staff@10769
     7
staff@10769
     8
staff@10769
     9
The jslint4java is an older version as the newer versions of jslint (1.3.3 for example) ship with Rhino included.
staff@10769
    10
This conflicts with yuicompressor which is also shipped with rhino (and even changes certain Rhino classes.
staff@10769
    11
staff@10769
    12
NOTE: do not upgrade jslint to a newer version without analyzing if these conflicts still occur.
staff@10769
    13
harpreet@9076
    14
The conflict is reported by a RuntimeException (when compressing) in the YUICompressor class JavascriptCompressor (line 299).